Interkoneksi Jaringan Menggunakan Routing Protokol OSPF dengan Quagga

Secara garis besar disini akani dibahas pembangunan PC router dengan menggunakan Sistem Operasi Linux Ubuntu 10.10. Diantaranya Instalasi Quagga/Zebra, Konfigurasi Quagga/Zebra, dan Implementasi pada jaringan. Pada instalasi Quagga/Zebra akan dijelaskan secara rinci pada sub bab Instalasi Quagga/Zebra hingga Quagga siap untuk digunakan. Untuk Konfigurasi Quagga/Zebra selengkapnya akan di jelaskan lebih detail pada sub bab Konfigurasi dan implementasi pada jaringan. Penulis melakukan pengimplementasian PC Router ini di rumah.

3.1     Instalasi Quagga
Hal pertama yang dilakukan saat penginstalan Quagga ini adalah dengan memastikan bahwa komputer ini terhubung dengan koneksi internet. Untuk memastikan koneksi internet yang terhubung yaitu dengan cara masuk kedalam terminal dan login sebagai root dengan perintah SUDO SU lalu memasukkan password yang telah di buat pada saat penginstalan Sistem Operasi. Kemudian mengecek IP address yang terhubung dengan internet dengan perintah ifconfig. Setelah IP address sesuai dan dapat terhubung internet, maka dapat langsung menginstallnya seperti gambar dibawah

Setelah Quagga selesai terinstall, kemudian edit daemon file di dalam directory /etc/quagga/ seperti gambar dibawah

Saat selesai memasukkan vim/etc/quagga/daemons tadi, akan muncul isi dari file daemon di dalam directory /etc/quagga seperti gambar dibawah

Isi dari file daemons, terdapat Zebra, BGPD, OSPFD, OSPF6d, RIPD, dan ISISD. Semua itu merupakan protokol yang akan digunakan untuk melakukan proses routing. Untuk protokol Zebra, itu merupakan protokol wajib yang harus diaktifkan karena Zebra menghubungkan software Quagga ke dalam kernel. Pada penulisan ini saya akan mengaktifkan protokol OSPF karena kita akan menggunakan protokol ini untuk melakukan proses routing. Cara mengaktifkan zebra dan protokol ospf cukup mengganti “no” menjadi “yes”. Setelah kita ganti zebra = no menjadi zebra = yes dan ospfd = no menjadi ospfd = yes lalu kita save dan keluar dari mode edit. Setelah kita keluar dari mode edit lalu kita cek file daemon apakah kedua protocol tersebut sudah aktif atau belum aktif seperti gambar dibawah


Dari gambar diatas  zebra dan protokol ospf sudah aktif dan siap digunakan untuk proses routing. Karena pada saat mengubah file daemons yang penulis pakai adalah protocol Zebra dan protocol OSPF, maka yang di salin file konfigurasinya zebra.conf dan ospfd.conf dengan perintah cp /usr/share/quagga/samples/zebra.conf.sample /etc/quagga/zebra.conf.

Perintah cp adalah perintah untuk menyalin sebuah file. Sehingga file zebra.conf.sample yang terdapat pada direktori /usr/share/doc/quagga/ akan disalin kedalam direktori /etc/quagga/ dan filenya diubah menjadi zebra.conf. Begitu juga dengan protocol ospf, kita salin file konfigurasinya ospfd.conf dengan perintah cp /usr/share/doc/quagga/examples/ospfd.conf.sample /etc/quagga/ospfd

Setelah menyalin file konfigurasi, daemon protocol diaktifkan dengan perintah /etc/init.d/quagga start

Quagga start adalah perintah untuk mengaktifkan Quagga. Selain quagga start, terdapat juga perintah quagga restart untuk merestart quagga dan meruba konfigurasi menjadi semula, dan juga quagga stop untuk menghentikan aplikasi quagga.
Untuk masuk kedalam Zebra dan OSPF dengan cara menggunakan melakukan Telnet ke IP localhost dengan port dari aplikasi routing protocol. Untuk mengetahui port dari aplikasi routing protocol dapat dilihat seperti gambar seperti dibawah

Dari netstat yang muncul pada protocol zebra dan protocol ospf, dapat dilihat bahwa port yang di gunakan untuk melakukan telnet adalah 2601 dan 2604. IP yang dituju adalah 127.0.0.1 atau yang disebut IP localhost. Dengan demikian untuk masuk kedalam zebra, dilakukan dengan menggunakan port tersebut, dengan cara seperti gambar dibawah

Telnet localhost 2601 dan Telnet localhost 2604 adalah perintah untuk menghubungkan ke localhost atau ke dalam komputer itu sendiri dengan nomor port 2601 dan 2604, sehingga telnet dilakukan pada localhost dan yang dituju adalah port 2601 dan 2604 atau port Zebra dan port OSPFD untuk menjalankan software quagga. Pada saat muncul tampilan trying 127.0.0.1, artinya telnet sedang mencoba untuk mengkoneksi ke IP localhost yaitu 127.0.0.1. Tampilan Connected to localhost. localdomain. menandakan bahwa telnet berhasil dilakukan dan berhasil terkoneksi. Tampilan Escape character is ‘^]’. menjelaskan bahwa untuk keluar dari software quagga dapat menggunakan karakter ^]. Lalu Hello, this is Quagga hanya banner yang memberikan informasi tentang versi Quagga dan juga Copyright beserta pembuatnya yaitu Kunihiro Ishigiro. Dan untuk memulai konfigurasi Quagga di butuhkan password untuk masuk kedalam Quagga nya. Password default dari Quagga ini adalah “zebra”, dan password ini dapat diubah demi keamanan PC Router ini.

3.2     Konfigurasi dan Implementasi Quagga pada Jaringan
Quagga sudah diinstall dan siap digunakan atau diimplementasikan untuk membangun jaringan computer, selanjutnya Quagga dikonfigurasi sesuai topologi jaringan. Pengimplementasian ini menggunakan 2 PC yang dijadikan PC Router dan laptop yang akan di uji sebagai client untuk uji coba jaringan. Topologi yang dibuat pada implementasi yang penulis lakukan seperti gambar dibawah

Pada gambar terdapat 2 buah PC router yang saling berhubungan dimana masing-masing PC router memiliki lebih dari 1 koneksi antar router. Hal ini memiliki tujuan jika pada suatu saat salah satu jaringan mati router akan tetap dapat meneruskan paket data ke tujuan menggunakan jalur yang lain sehingga mencegah terputusnya aliran data pada saat pengiriman paket data. Topologi ini terdiri dari empat network, yaitu network 192.168.1.0/30 dan 192.168.4.0/30 yang menghubungkan PC router dan network 192.168.5.0/30 dan 192.168.3.0/30 sebagai jaringan client.
Konfigurasi pertama adalah PC Router 1 terlebih dahulu. Langkah pertama adalah memberi IP Address terlebih dahulu didalam zebra. Pertama kita masuk ke zebra yang ada di PC Router 1 dengan perintah telnet localhost 2601.

Lalu kita masukkan password ‘zebra’. Jika kita sudah memasukkan password dengan benar maka kita akan masuk ke dalam Quagga dan kita siap melakukan konfigurasi.

Router> enable
    
Perintah enable digunakan untuk masuk ke dalam privilege mode dimana konfigurasi dilakukan.
Router# configure terminal

Setelah masuk ke dalam privilege mode, maka tanda > akan berubah menjadi #. Untuk masuk kedalam mode konfigurasi maka perintah yang digunakan adalah configure terminal.

Jika kita sudah meberikan perintah configure terminal maka kita akan masuk ke dalam mode konfigurasi.

Router(config)#

Lalu selanjutnya kita masukkan IP address untuk PC router ubuntu-1 pada eth1, eth3 dan eth4, seperti yang terlihat pada gambar dibawah

Setelah memasukkan IP address, kita cek terlebih dahulu apakah IP sudah dimasukkan ke dalam interface yang seharusnya. Cara mengeceknya kita dapat memberikan perintah show running-config atau dapat kita singkat dengan sh run seperti pada gambar dibawah

Selain kita memasukkan IP address didalam Zebra kita juga sebaiknya memasukkan IP address di dalam PC Router 1 secara manual, caranya dengan login sebagai root. Lalu memasukkan perintah root@enz: /home/edwinhermawann# gedit /etc/network/interfaces

Lalu kita isi file interfaces seperti pada gambar dibawah

IP address sudah dimasukkan ke dalam PC Router 1. Sekarang kita masukkan protokol routing ke dalam PC Router 1. Pertama kita login ke OSPFD di PC Router 1

Lalu kita masukkan password ‘zebra’. Jika kita sudah memasukkan password dengan benar maka kita akan masuk ke dalam Quagga dan kita siap melakukan konfigurasi.
ospfd> enable

Perintah enable digunakan untuk masuk ke dalam privilege mode dimana konfigurasi dilakukan.

ospfd # configure terminal

Setelah masuk ke dalam privilege mode, maka tanda > akan berubah menjadi #. Untuk masuk kedalam mode konfigurasi maka perintah yang digunakan adalah configure terminal.
Jika kita sudah meberikan perintah configure terminal maka kita akan masuk ke dalam mode konfigurasi.

ospfd(config)#router ospf
ospfd(config-router)#network 192.168.1.0/30 area 0
ospfd(config-router)#network 192.168.4.0/30 area 0
ospfd(config-router)#network 192.168.5.0/30 area 0
ospfd(config-router)#network 1.1.1.1/30 area 0

Perintah diatas merupakan perintah untuk konfigurasi routing OSPF. Kita harus masuk ke dalam mode router yaitu dengan perintah ospfd(config)#router ospf. Setelah kita masuk ke dalam mode router maka kita masukkan network yang berada dibagian PC router ubuntu-1 adalah 192.168.1.0, 192.168.4.0, 192.168.5.0 dan 1.1.1.1. “/30” merupakan CIDR yang menandakan network tersebut memiliki subnet mask 255.255.255.252 yang hanya memiliki 2 host.

Lalu yang kedua kita konfiguras PC Router 2. Langkah pertama adalah memberi IP Address terlebih dahulu.

Lalu kita masukkan password ‘zebra’. Jika kita sudah memasukkan password dengan benar maka kita akan masuk ke dalam Quagga dan kita siap melakukan konfigurasi.
Router> enable
Perintah enable digunakan untuk masuk ke dalam privilege mode dimana konfigurasi dilakukan.

Router# configure terminal

Setelah masuk ke dalam privilege mode, maka tanda > akan berubah menjadi #. Untuk masuk kedalam mode konfigurasi maka perintah yang digunakan adalah configure terminal.
Jika kita sudah meberikan perintah configure terminal maka kita akan masuk ke dalam mode konfigurasi.

Router(config)#

Lalu selanjutnya kita masukkan IP address untuk PC router ubuntu pada eth0, eth2 dan eth3.

Selain kita memasukkan IP address didalam Quagga kita juga sebaiknya memasukkan IP address di dalam PC router secara manual, caranya dengan login sebagai root. Lalu memasukkan perintah root@enz: /home/edwinhermawann# gedit /etc/network/interfaces.

IP address sudah dimasukkan ke dalam PC router Ubuntu. Sekarang kita konfigurasi routing protocol ke dalam PC Router. Untuk melakukan konfigurasi routing protokol pada router pertama kita masuk ke dalam OSPFD. Kita masuk ke dalam ospfd dengan perintah telnet localhost 2604

Lalu kita masukkan password ‘zebra’. Jika kita sudah memasukkan password dengan benar maka kita akan masuk ke dalam Quagga dan kita siap melakukan konfigurasi.
ospfd> enable

Perintah enable digunakan untuk masuk ke dalam privilege mode dimana konfigurasi dilakukan.

ospfd # configure terminal

Setelah masuk ke dalam privilege mode, maka tanda > akan berubah menjadi #. Untuk masuk kedalam mode konfigurasi maka perintah yang digunakan adalah configure terminal.

Jika kita sudah meberikan perintah configure terminal maka kita akan masuk ke dalam mode konfigurasi.

ospfd(config)#router ospf
ospfd(config-router)#network 192.168.1.0/30 area 0
ospfd(config-router)#network 192.168.4.0/30 area 0
ospfd(config-router)#network 192.168.3.0/30 area 0
ospfd(config-router)#network 2.2.2.2/30 area 0

Perintah diatas merupakan perintah untuk konfigurasi routing OSPF. Kita harus masuk ke dalam mode router yaitu dengan perintah ospfd(config)#router ospf. Setelah kita masuk ke dalam mode router maka kita masukkan network yang berada dibagian PC router ubuntu adalah 192.168.1.0, 192.168.4.0, 192.168.3.0 dan 2.2.2.2. “/30” merupakan CIDR yang menandakan network tersebut memiliki subnet mask 255.255.255.252 yang hanya memiliki 2 host.
Sampai disini kita sudah menghubungkan 2 PC router. Masing-masing PC router memiliki 3 jaringan yang berbeda. Pada PC router 1 dikonfigurasi memiliki jaringan 192.168.1.0/30, 192.168.4.0/30 dan 192.168.5.0/30 sedangkan pada PC router 2 dikonfigurasi memiliki jaringan 192.168.1.0/30, 192.168.4.0/30 dan 192.168.3.0/30.
Selanjutnya cek route IP pada mode router pada PC router yang pertama dikonfigurasi dan PC router yang kedua dikonfigurasi. Hasil routing OSPF pada kedua PC router seperti pada gambar dibawah

Dari gambar menyatakan hasil dari routing OSPF disalah satu router dan router tersebut memiliki hubungan antar router lebih dari satu jalur. Seperti gambar dibawah yang menyatakan bahwa untuk terhubung ke jaringan 192.168.3.0/30 router dapat melewati interface eth1 dengan network 192.168.1.0/30 gateway 192.168.1.2 atau melalui interface eth4 dengan network 192.168.4.0/30 gateway 192.168.4.1.

Pernyataan diatas pada saat jalur keduanya aktif. Apabila salah satu jalur terputus maka routing table akan berubah sesuai dengan keadaan. routing table pada saat salah satu jalur terputus seperti pada gambar dibawah

Dari gambar  diatas menyatakan bahwa jika salah satu jalur terputus maka PC Router akan tetap dapat melakukan komunikasi dengan jaringan sebelahnya dengan menggunakan jalur alternative. Dengan cara ini dapat meminimalisir terputus nya komunikasi data.

Jalur routing sudah terbentuk lalu selanjutnya kita akan konfigurasi PC Client dimana client tersebut akan saling berhubungan dengan PC router yang sudah di konfigurasi dengan protocol OSPF.

Lalu, langkah berikutnya adalah  PC Router harus diaktifkan IP Forwarding nya, untuk meneruskan IP address dan data dapat berhasil berjalan menuju network yang berbeda bahkan tidak terhubung secara langsung. Cara nya yaitu dengan perintah root@enz:~# echo 1 > /proc/sys/net/ipv4/ip_forward untuk PC router 1 dan root@amibios:~# echo 1 > /proc/sys/net/ipv4/ip_forward untuk PC router 2.
Kedua PC Router sudah dikonfigurasi sesuai dengan topologi yang sudah penulis rancang sebelumnya. Langkah terakhir adalah memberi IP Address pada kedua PC Client, dan melakukan ping ke Gateway, jaringan lain, dan terakhir PC Client lain. Untuk PC Client 1 konfigurasi IP nya :

–    IP address : 192.168.5.1
–    Subnet Mask : 255.255.255.252
–    Default Gateway : 192.168.5.2

Untuk PC Client 2 konfigurasi IP nya :

–    IP address : 192.168.1.3
–    Subnet Mask : 255.255.255.0
–    Default Gateway : 192.168.1.1

Selanjutnya dilakukan test koneksi ke IP yang ada di PC Client 2. Untuk PC Client 1, tampilan ping nya ditunjukkan pada gambar dibawah

Dari  semua  hasil test koneksi yang telah ditunjukkan, dari PC Client 1 baik menuju PC Router 1, PC Router 2 maupun PC Client 2 yang secara topologi tidak terhubung langsung,  dengan routing protocol OSPF yang sudah didaftarkan pada kedua router, menghasilkan perjalanan data dari network satu menuju yang lainnya dapat berjalan dengan baik.

PENULISAN ILMIAH – MUHAMMAD EDWIN HERMAWAN

UNIVERSITAS GUNADARMA

2012

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s